Author Topic: Sub collections not working correctly  (Read 307 times)

ginzu

  • Newbie
  • *
  • Posts: 38
  • Karma: +1/-0
    • View Profile
Sub collections not working correctly
« on: September 26, 2021, 11:03:30 PM »
 :) Hi there!

It has been several years since I have touched my retrofe config.
In the meantime, my pc has been reinstalled once.
Since then, my sub collections no longer launch games .. any idea?

My retrofe/collection/main.txt :

MAME_0220
Ringedge
NEO_GEO
PopCap
Fighting
MAME_beatthemall
Shmups
Sammy Atomiswave
Taito type X
Nesica
Sega Genesis
Nintendo Entertainment System

Example: the sub NEO_GEO won't launch the games.

inside collection/NEO_GEO/settings.conf :
Code: [Select]
# Uncomment and edit the following line to use a different ROM path.
#list.path = %BASE_ITEM_PATH%\%ITEM_COLLECTION_NAME%\roms
list.includeMissingItems = false
list.extensions = zip
list.menuSort = yes

launcher = MAME

#metadata.type = MAME


#media.screenshot      = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\screenshot
#media.screentitle     = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\screentitle
#media.artwork_back    = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\artwork_back
#media.artwork_front   = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\artwork_front
#media.logo            = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\logo
#media.medium_back     = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\medium_back
#media.medium_front    = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\medium_front
#media.screenshot      = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\screenshot
#media.screentitle     = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\screentitle
#media.video           = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\medium_artwork\video
#media.system_artwork  = %BASE_MEDIA_PATH%\%ITEM_COLLECTION_NAME%\system_artwork

But in my collection/MAME_0220/settings.conf :

Code: [Select]
###############################################################################
# The location of where your ROM items exist. Examples:
list.path = G:\Download\MAME_BRUCE\roms
#list.path = ..F:\JEUX\ROMS_MAME_0193                (relative path to root of FE dir)
#
# If BASE_ITEM_PATH=D:/ROMs and the name of this collection is named "Arcade"
# then the configuration below will search in D:/ROMs/Arcade
###############################################################################
#list.path = %BASE_ITEM_PATH%/%ITEM_COLLECTION_NAME%/roms

###############################################################################
# If a game is specified in include.txt then it will be included in the list
# regardless of if the rom actually exists or not. Set this variable to false
# to exclude any items that cannot be found.
###############################################################################
list.includeMissingItems = false

###############################################################################
# Extensions are comma separated without spaces
###############################################################################
list.extensions = zip

###############################################################################
# If a menu.xml file exists, it will display the menu alphabetically. To
# not auto-sort the menu items alphabetically, set the following to false.
# This does not apply to how your ROMs are sorted.
###############################################################################
list.menuSort = true

###############################################################################
# The executable to run when an item in a collection item is selected
###############################################################################
launcher = %ITEM_COLLECTION_NAME%

###############################################################################
# On default, MAME roms are not clearly named. We need to use the MAME
# metadata for them.
###############################################################################
metadata.type = %ITEM_COLLECTION_NAME%

###############################################################################
# Default media paths to scan for artwork. Uncomment and edit to override
# the default values.
#
# media.screenshot    = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/screenshot
# media.screentitle   = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/screentitle
# media.artwork_back  = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/artwork_back
# media.artwork_front = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/artwork_front
# media.logo          = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/logo
# media.medium_back   = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/medium_back
# media.medium_front  = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/medium_front
# media.screenshot    = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/screenshot
# media.screentitle   = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/screentitle
# media.video         = %BASE_MEDIA_PATH%/%ITEM_COLLECTION_NAME%/medium_artwork/video
###############################################################################

media.logo            = G:\Media\MAME\Images\Wheel
media.logo            = G:\Media\MAME\Images\Wheel
media.video           = G:\Media\MAME\Video
media.artwork_front   = G:\Media\MAME\Images\arcade flyers

Games are well listed in my /collections/NEO_GEO/MAME.sub and they show up correctly in the frontend.
When i click on the game, they won't launch.

games only start from the MAME_0220 collection list.

I also tried to change launcher =MAME with launcher = %ITEM_COLLECTION_NAME% .... in the NEO_GEO collections/settings.conf file.

 :o  what 's happening ?  it worked like that before......

i attached the log file where i can see the following message :
(
[2021-09-26 23:56:01] [ERROR] [Launcher] Failed to find launcher executable (launcher: MAME executable: )
but i don't understand ....

within the /retrofe/launcher/MAME_0220 :
executable = F:\Emulators\MAME_0220\arcade64.exe
arguments = "%ITEM_NAME%"

thank you.    :-\

Ʉ₦₳Vě₩ɆĐ

  • Newbie
  • *
  • Posts: 43
  • Karma: +25/-13
  • CORE
    • View Profile
Re: Sub collections not working correctly
« Reply #1 on: September 27, 2021, 01:03:46 AM »
your NEO_GEO settings.conf is using mame launcher.
is this intended?

if you changed to launcher = %ITEM_COLLECTION_NAME% then you need a launcher named NEO_GEO.conf

to me it looks like you need to be using launcher = MAME_0220
or you need a NEO_GEO launcher

but none of this explains why it used to work but now doesnt.
« Last Edit: September 27, 2021, 01:12:44 AM by Ʉ₦₳Vě₩ɆĐ »

ginzu

  • Newbie
  • *
  • Posts: 38
  • Karma: +1/-0
    • View Profile
Re: Sub collections not working correctly
« Reply #2 on: September 27, 2021, 05:55:30 AM »
OK! I'm dumb!  ::)

it was so simple that I couldn't remember! The name of the launcher is simply the name of the laucher.conf ! Indeed, a long time ago I used the collection named MAME but in the meantime, I had tested different versions of MAME and I stayed on the 0220 but I had not corrected the launcher in the configurations of the sub collections! thanks to you, it works perfectly now!

So what i did :
I rename the sub file in my collections/NEO_GEO correctly : MAME_0220.sub
I called the right launcher in my collections/NEO_GEO/settings.conf file : launcher = MAME_0220
« Last Edit: September 27, 2021, 06:01:46 AM by ginzu »

Ʉ₦₳Vě₩ɆĐ

  • Newbie
  • *
  • Posts: 43
  • Karma: +25/-13
  • CORE
    • View Profile
Re: Sub collections not working correctly
« Reply #3 on: October 25, 2021, 09:40:28 PM »
glad it's sorted  :D