Author Topic: RetroFE development  (Read 19691 times)

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1030
  • Karma: +18/-0
    • View Profile
    • Towel 42
RetroFE development
« on: December 07, 2016, 10:36:24 AM »
I have created an issue list on bitbucket: https://bitbucket.org/phulshof/retrofe/issues?status=new&status=open
You can find all the feature requests there, and I will update it as features get added and/or as feature requests come in. :)
« Last Edit: May 28, 2017, 08:11:23 AM by Pieter Hulshoff »

JonahUK

  • Guest
Re: New features
« Reply #1 on: December 10, 2016, 05:00:16 PM »
Would love to see per system themes at some point without using workarounds such as two or three tier menus :)

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1030
  • Karma: +18/-0
    • View Profile
    • Towel 42
Re: New features
« Reply #2 on: December 10, 2016, 05:23:55 PM »
Per system themes already work, unless you mean per menu item themes so each system can look differently on the main menu.

Sent from my SM-G920F using Tapatalk


JonahUK

  • Guest
Re: New features
« Reply #3 on: December 10, 2016, 07:02:37 PM »
Lol, yes, per menu item is what I meant :)

Tom Acunzo

  • Newbie
  • *
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: New features
« Reply #4 on: December 22, 2016, 12:37:12 AM »
I just pushed out the RetroFE MacOS build to my fork!

I noticed that you recently added new changes to yours. I guess I have to sync what's changed between the two builds? I'm new to bitbucket so any tips would be appreciated before I issue a PR.

Notes:
* I updated the README.md. Linking URLs outside seems broken, leaving out quotes makes links internal.
* The RetroFE brew formula isn't live. So brew install won't be active yet.
* I assigned 0.7.20 in the Version.cpp. Is this about right?
* I patched png files with pngcrush (see readme)
* I used the icon from fan art.

I found a bug in RetroFE that I also confirmed with emp.
RetroFE will crash during the routine exit / quit if a Dualshock 3 controller is still mounted via usb or with bluetooth. I don't know if this will happen with other controllers but it's easy to test.
« Last Edit: December 22, 2016, 12:43:59 AM by Tom »

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1030
  • Karma: +18/-0
    • View Profile
    • Towel 42
Re: New features
« Reply #5 on: December 22, 2016, 09:13:48 AM »
Normal procedure is to merge my latest code with your branch, double check, and then do a pull request. Version 0.7.20 is fine, but for the future I'd prefer it if you leave the version numbering to me. :)

I'm aware of the crash, but I haven't been able to reproduce it yet, so I haven't been able to debug the problem yet either. It's on the todo list though, but if you feel like debugging it before I have time, please feel free. :) I'd appreciate the help in this regard.

Tom Acunzo

  • Newbie
  • *
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: New features
« Reply #6 on: December 22, 2016, 10:30:31 AM »
Noted. ;D  I merged your changes with mine and RetroFE ran well locally. I pushed them back to my fork to keep things in sync. I have a couple brew tests before creating the pull request. I'll keep you posted.

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1030
  • Karma: +18/-0
    • View Profile
    • Towel 42
Re: New features
« Reply #7 on: December 22, 2016, 11:43:42 AM »
Thanks. :) Looking forward to seeing your work. I'm hoping to get some people to test on Windows soon; I'm not 100% sure all changes I made will compile under Windows.

Tom Acunzo

  • Newbie
  • *
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: New features
« Reply #8 on: December 22, 2016, 10:51:16 PM »
I'm happy to contribute! The more platforms the merrier right? I just sent you a PR.  8)

We need some test users from the community. Maybe as people introduce themselves they can specify their platform of choice. There are definitely some unknowns out there for each platform.

Nothing major but I was checking the RetroFE logs and I notice some output about missing directories / files that may have something to do with an out of sync Package/Environment/* in bitbucket.

I ran out of time to investigate but one that stood out to me was:
/meta/hyperlist/ was in bitbucket but I didn't see /meta/mamelist in there. You see messages in the logs.

grep not log.txt
[2016-12-22 07:36:11] [INFO] [Configuration] Could not open /usr/local/Cellar/retrofe/0.7.20/collections/Main/info.conf"
[2016-12-22 07:36:13] [ERROR] [CollectionInfoBuilder] Could not read directory "/usr/local/Cellar/retrofe/0.7.20/meta/mamelist"
[2016-12-22 07:36:18] [INFO] [CollectionInfoBuilder] Could not read directory "/usr/local/Cellar/retrofe/0.7.20/collections/Main/roms". Ignore if this is a menu.

Perhaps that's an empty folder in need a of file or dot file?

I also recall messages about missing layout.xml inside of collections/layout. Would a layout folder be inside collections? I wasn't able to reproduce that so it might have been a fluke of an older build. Unsure.  :-\

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1030
  • Karma: +18/-0
    • View Profile
    • Towel 42
Re: New features
« Reply #9 on: December 23, 2016, 07:35:45 AM »
I think those messages should be (changed to) INFO messages. Those are optional files that do not need to be there.

Thank you for the changes by the way. It's great that RetroFE will also be working on MAC-OS. :) Next step is to have someone do a Windows build to make sure everything still compiles on that OS; I may need to change some code in the hierarchical rom directory support for that.
« Last Edit: December 23, 2016, 07:40:47 AM by Pieter Hulshoff »

Agent47

  • Global Moderator
  • Full Member
  • *****
  • Posts: 114
  • Karma: +4/-1
    • View Profile
Re: New features
« Reply #10 on: December 23, 2016, 03:01:50 PM »
I tried doing a windows build last night and ran into a cmake error when generating the VS project. I'm gonna give it another go to make sure I didn't do anything dumb last night (it was late). I've compiled it in the past w/o issue so not sure if I just messed something up this time or if something has changed.

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1030
  • Karma: +18/-0
    • View Profile
    • Towel 42
Re: New features
« Reply #11 on: December 23, 2016, 04:40:36 PM »
Changes were made, so I'm very interested in the error messages. I do not have a Windows compile environment.
« Last Edit: December 23, 2016, 05:59:20 PM by Pieter Hulshoff »

Agent47

  • Global Moderator
  • Full Member
  • *****
  • Posts: 114
  • Karma: +4/-1
    • View Profile
Re: New features
« Reply #12 on: December 23, 2016, 04:59:39 PM »
I'll have to confirm later but I believe the error was that gstreamer_gstappsink_INCLUDE_DIR was set to notfound or something along those lines.

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1030
  • Karma: +18/-0
    • View Profile
    • Towel 42
Re: New features
« Reply #13 on: December 23, 2016, 05:58:32 PM »
That doesn't sound like something I touched recently. 😀

Which code did you compile exactly?

Tom Acunzo

  • Newbie
  • *
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: New features
« Reply #14 on: December 23, 2016, 11:34:11 PM »
I'll have to confirm later but I believe the error was that gstreamer_gstappsink_INCLUDE_DIR was set to notfound or something along those lines.

Hi Agent try updating: retrofe\RetroFE\CMake\FindGStreamer.cmake
on line 46
SET(GSTREAMER_INCLUDE_DIRS ${GSTREAMER_gst_INCLUDE_DIR} ${GSTREAMER_gstconfig_INCLUDE_DIR} ${GSTREAMER_gstappsink_INCLUDE_DIR})

to
SET(GSTREAMER_INCLUDE_DIRS ${GSTREAMER_gst_INCLUDE_DIR} ${GSTREAMER_gstconfig_INCLUDE_DIR})

Let me know how it goes. If all is well. I'll just have to check how that change impacts the Mac build.