Author Topic: wav inhibits jpg  (Read 891 times)

lordbah

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
wav inhibits jpg
« on: September 16, 2021, 07:35:10 PM »
Hello,
I don't know enough yet to know whether what I see is behavior of RetroFE or of the Ergo Proxy theme. Usually, the lower right corner is populated with a still image from the video folder, (romname).(jpg/png). However if I put (romname).wav in that folder, the wav is played, but no still image is loaded (see attached). This choice makes no sense to me. Can I get it to do both?

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1494
  • Karma: +45/-4
    • View Profile
    • Towel 42
Re: wav inhibits jpg
« Reply #1 on: September 19, 2021, 07:22:31 AM »
RetroFE only loads a single file per tag in the layout.xml file, and it does so with a certain priority. What you can do is copy the reloadableVideo tag, and setting the type for that tag to e.g. audio. You can then move the .wav file in the audio directory of your collection (just create one right next to your video directory), and it will find the wav file with the newly created second tag and the image with the original tag.

lordbah

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: wav inhibits jpg
« Reply #2 on: September 19, 2021, 10:17:49 PM »
Apparently I'm not doing it correctly. It shows the jpg now but does not play the audio.

I created the folder 'audio' parallel to 'video', moved *.wav from video/ to ../audio, edited layouts/Ergo Proxy/layout.xml to add (says 'audio' where the other tag says 'screenshot')

  <reloadableVideo imageType="audio" alpha="1" x="center" y="center" yOrigin="center" xOrigin="center" yOffset="-67" xOffset="4" width="678" height="508" layer="5" >  ^M
  </reloadableVideo>

I didn't copy the onEnter, onMenuScroll, etc because the concept of animation didn't seem to mean anything for audio.

What tells it to look in the folder named 'audio' for imageType="audio"? Is that built-in? I ran strace ./RetroFE (I'm on Linux) and did not find any open() call on any path in the audio folder.

lordbah

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: wav inhibits jpg
« Reply #3 on: September 20, 2021, 08:40:37 PM »
Poking around the documentation I saw there is a <reloadableAudio> tag. So I changed what I added to <reloadableAudio>. Same behavior, shows jpg but does not play audio.

lordbah

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: wav inhibits jpg
« Reply #4 on: September 21, 2021, 02:08:36 AM »
Aside: the source code links on the download page aren't working.

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1494
  • Karma: +45/-4
    • View Profile
    • Towel 42
Re: wav inhibits jpg
« Reply #5 on: September 21, 2021, 04:52:03 PM »
<reloadableVideo type="audio" alpha="1" x="center" y="center" yOrigin="center" xOrigin="center" yOffset="-67" xOffset="4" width="678" height="508" layer="5" ></reloadableVideo>

You used imageType in stead of type. imageType is the backup image directory it looks in when it cannot find an acceptable file in the main directory.
Yes, you can use reloadableAudio as well; the two tags work exactly the same.

lordbah

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: wav inhibits jpg
« Reply #6 on: September 21, 2021, 08:29:32 PM »
Yeah I copied an existing tag which had imageType but not type and assumed that I knew what you meant by "type", but I was wrong. Using "type" it does what I want :-)

Thanks.