Author Topic: Retro FE list.includeMissingItems set to true and not seeing ROMS.  (Read 182 times)

jerim79

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Hello. I am new to the group. I am setting up Retro FE for the first time. I have chosen to use retroarch, as I am more familiar with it and it appears to handle more systems. I have gone through the tutorials and I believe I have everything setup as I should, but it seems that Retro FE can't find the roms. If I have list.includeMissingItems set to false, then no roms show up. This applies to all systems I am setting, but for the sake of this thread, I am just doing Atari 5200. In RetroFE\meta\hyperlist folder, I have the attached Atari 5200.xml file. In the RetroFE\launchers.windows folder I have the attached Atari 5200.conf file. In the RetroFE\collections\Atari 5200 folder, I have the attached settings.conf file.

I have the Retro FE collection pack so have all the artwork, videos and info for everything for Atari 5200. If I set list.includeMissingItems to true, everything shows as you would expect. I do have the roms in the RetroFE\collections\Atari 5200\roms folder. They are .7z format and that format is added to list.extensions as you can see in settings.conf. Any help will be greatly appreciated.

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1117
  • Karma: +18/-0
    • View Profile
    • Towel 42
Retro FE list.includeMissingItems set to true and not seeing ROMS.
« Reply #1 on: May 13, 2019, 06:30:48 AM »
I may be wrong, but I donít think RetroFE supports that space in the extension list. Thatís something I should perhaps fix in the future.

jerim79

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
I removed the space and have attached the new settings.conf file. It still won't display the roms.

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1117
  • Karma: +18/-0
    • View Profile
    • Towel 42
Could you upload your log.txt file as well?
Also, you mentioned the RetroFE collection pack: is this the one from EmuMovies by chance? If so, did you remove/rename the include.txt file in the Atari5200 collection?

jerim79

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
You were correct. I renamed the include.txt file and the issue has been resolved. Thank you so much.
(For some reason, I was thinking that file only mattered if you had ROMs listed in it. Otherwise it was ignored.)

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1117
  • Karma: +18/-0
    • View Profile
    • Towel 42
That's good to hear. :) Enjoy your setup.