Author Topic: Failed to find launcher executable  (Read 291 times)

xiaoxiao181

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Failed to find launcher executable
« on: April 01, 2019, 08:25:41 PM »
[2019-04-01 13:48:43] [ERROR] [Launcher] Failed to find launcher executable (launcher: Sony PlayStation 1 executable: )
[2019-04-01 13:48:43] [DEBUG] [Page] Allocating graphics memory
[2019-04-01 13:48:44] [DEBUG] [Page] Allocate graphics memory complete


Now, originally in launcher.windows there is no Sony Playstation 1 conf file, so I copied a random one and changed the contents to:

executable = emulators\PS1\ePSXe.exe
arguments = "%ITEM_FILEPATH%"

I know for a fact the pathing is correct, and the exe exists, yet when I try to launch a game, the screen goes dark for a second like it's about to start the software, but then reverts back to the games list instead.

I also failed to notice that there was a conf file named "PS1" already in there, so I changed that to match the emulator path as well. Same results. Screen goes dark for a second but then reverts back to the games list.

THEN, checking the settings.conf file in the ps1 collections folder, I changed:

launcher = PS1
#metadata.type = Sony PlayStation 1

So that it would match it properly, whereas before it was:

launcher = Sony Playstation 1
#metadata.type = Sony PlayStation 1

to match the new conf I had made earlier. THIS time, however, while I still get the same results of the screen going dark and reverting back to the games list without launching the launcher, the log now states this:

[2019-04-01 14:13:05] [WARNING] [Launcher] Checking to see if "R:\collections\Sony Playstation 1\roms\Castlevania Symphony of the Night.zip" exists  [No]
[2019-04-01 14:13:05] [INFO] [Launcher] Checking to see if "R:\collections\Sony Playstation 1\roms\Castlevania Symphony of the Night.bin" exists  [Yes]
[2019-04-01 14:13:05] [INFO] [Launcher] Attempting to launch: "emulators\PS1\ePSXe.exe" -nogui -cdfile "R:\collections\Sony Playstation 1\roms\Castlevania Symphony of the Night.bin"
[2019-04-01 14:13:05] [INFO] [Launcher]      from within folder: emulators\PS1
[2019-04-01 14:13:05] [INFO] [Launcher] Completed
[2019-04-01 14:13:05] [DEBUG] [Page] Allocating graphics memory
[2019-04-01 14:13:05] [DEBUG] [Page] Allocate graphics memory complete

Now my last attempt so far was to simply remove the [-nogui -cdfile] from the arguments, and that allowed a successful emulator launch, but the game did not launch.

I'm at a loss here lol...

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1117
  • Karma: +18/-0
    • View Profile
    • Towel 42
Re: Failed to find launcher executable
« Reply #1 on: April 01, 2019, 08:39:51 PM »
Step 1 is always to assure that your emulator is actually working. Have you tried launching the command from the log on the command line to see if it tells you anything? Missing bios files for instance?

xiaoxiao181

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Failed to find launcher executable
« Reply #2 on: April 01, 2019, 09:12:09 PM »
R:\emulators\PS1\ePSXe.exe "R:\collections\Sony Playstation 1\roms\Creatures.bin"

Ran it from the Cmd window. It straight refuses to run the game whether it's a bin or an img file.

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1117
  • Karma: +18/-0
    • View Profile
    • Towel 42
Re: Failed to find launcher executable
« Reply #3 on: April 01, 2019, 09:23:25 PM »
R:\emulators\PS1\ePSXe.exe "R:\collections\Sony Playstation 1\roms\Creatures.bin"

Ran it from the Cmd window. It straight refuses to run the game whether it's a bin or an img file.

That's probably why it won't run from RetroFE either. Unfortunately, I'm not familiar with ePSXe, so I don't know exactly what the command should look like either. You could try running the emulator standalone to see if you at least have all the necessary files (bios?) available. If it runs from the gui, figure out what the correct command line options for it are. :)

xiaoxiao181

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Failed to find launcher executable
« Reply #4 on: April 01, 2019, 09:33:42 PM »
That's ok, after a boat-load of googling and a lot of experimentation, I fixed mine by doing this:

executable = emulators\PS1\ePSXe.exe
arguments = -nogui -loadbin "%ITEM_FILEPATH%"

For future reference, in case anyone else needs help with this as well. :)

(By the way, RetroFE is by far the most amazing and simple to use frontend I've come across.)
All the settings are input manually instead of through a clunky gui like rocketlauncher or launchbox, plus it has a nice (actual arcade style) menu instead of the windows-like menu you get with other frontends, which defeat the entire purpose XD