Author Topic: Sega Model 2 not load the games  (Read 8661 times)

shc

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Sega Model 2 not load the games
« on: March 03, 2018, 08:37:57 PM »
Greetings to all. I am configuring a bartop with RetroFe and when configuring emulators I have a problem. The last one has been the Sega Model 2. When selecting a game from the RetroFe the emulator opens in a window but not the rom of the game.

These are the configurations that I have for this emulator:

executable = C:\RetroFE\emulators\Sega Model 2\emulator.exe
arguments = /open "%ITEM_FILEPATH%" /play /exit

And the settings:

list.path = %BASE_ITEM_PATH%\%ITEM_COLLECTION_NAME%\roms

Can you help me with this problem? I hope your answer.

Thank you very much.

 

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1536
  • Karma: +46/-14
    • View Profile
    • Towel 42
Sega Model 2 not load the games
« Reply #1 on: March 03, 2018, 10:43:15 PM »
That looks like a launcher setup for Future Pinball; I don’t use the Sega Model 2 emulator myself, but from what I could find it should be set up more like a MAME launcher.
« Last Edit: March 03, 2018, 11:05:30 PM by Pieter Hulshoff »

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1536
  • Karma: +46/-14
    • View Profile
    • Towel 42
Re: Sega Model 2 not load the games
« Reply #2 on: March 04, 2018, 08:09:55 AM »
Try the MAME arguments in stead?
arguments = "%ITEM_NAME%"
As said: I'm not familiar with this emulator, but from what I could find, this is how it should be called. If the emulator knows where the roms are, it should be able to load it based on the name alone, just like MAME does.

StoningtonQB

  • Jr. Member
  • **
  • Posts: 65
  • Karma: +0/-0
    • View Profile
Re: Sega Model 2 not load the games
« Reply #3 on: May 19, 2018, 01:58:00 AM »
I stumbled across this thread and am also having the same problem. I already had the following:
executable = %BASE_ITEM_PATH%\Emulators\Model 2 Emulator\emulator.exe
arguments = "%ITEM_NAME%"

If I go to the command prompt and type 'emulator daytona' it starts the game right up but from RetroFE it just loads the emulator and no game. It's driving me crazy!
« Last Edit: May 19, 2018, 06:18:55 PM by StoningtonQB »

Pieter Hulshoff

  • Administrator
  • Hero Member
  • *****
  • Posts: 1536
  • Karma: +46/-14
    • View Profile
    • Towel 42
Re: Sega Model 2 not load the games
« Reply #4 on: May 19, 2018, 08:10:35 AM »
Can you upload your log.txt file?

Sent from my SM-G950F using Tapatalk


StoningtonQB

  • Jr. Member
  • **
  • Posts: 65
  • Karma: +0/-0
    • View Profile
Re: Sega Model 2 not load the games
« Reply #5 on: May 19, 2018, 06:17:53 PM »
Sure thing. Don't think it will be useful because it says it's "completed" once I close the emulator window but here it is...

johnm

  • Newbie
  • *
  • Posts: 32
  • Karma: +2/-0
    • View Profile
Re: Sega Model 2 not load the games
« Reply #6 on: May 20, 2018, 12:04:11 AM »


I just tried it using Pieters example and it worked, mind that the log file will still show completed if RetroFE finds the rom but if you haven't set up the rom path in the emulators settings then the emulator wont find the rom. What got me was i had to remove the ; from the path once i edited the original.

StoningtonQB

  • Jr. Member
  • **
  • Posts: 65
  • Karma: +0/-0
    • View Profile
Re: Sega Model 2 not load the games
« Reply #7 on: May 20, 2018, 12:11:42 AM »
I have done all of this already. What folder do you have your installation? What are you using for launcher arguments?

johnm

  • Newbie
  • *
  • Posts: 32
  • Karma: +2/-0
    • View Profile
Re: Sega Model 2 not load the games
« Reply #8 on: May 20, 2018, 12:31:43 AM »
My location is the c drive but i have it set up to be portable so its relative to the retrofe root folder, that way i can stick it on another drive or PC


My launcher is
executable = .\emulators\model 2\emulator.exe
arguments = %ITEM_NAME%

my collections settings is
list.path = ./roms/Model 2/roms

and my rom path settings in the model 2 emu is

Dir1=..\..\roms\Model 2\roms

I haven't went any further than just grabbing the model 2 emulator, dropping a few roms in and change the paths. It loaded and i had a quick game of zero gunner and checked sega rally loaded and thats it, no art, videos or even configuring controls

StoningtonQB

  • Jr. Member
  • **
  • Posts: 65
  • Karma: +0/-0
    • View Profile
Re: Sega Model 2 not load the games
« Reply #9 on: May 20, 2018, 01:24:47 AM »
My launcher is
arguments = %ITEM_NAME%
Thank you so much it was that little bit right there that helped!

I had:
arguments = "%ITEM_NAME%"

Once I removed the quotes it worked.

johnm

  • Newbie
  • *
  • Posts: 32
  • Karma: +2/-0
    • View Profile
Re: Sega Model 2 not load the games
« Reply #10 on: May 20, 2018, 09:13:31 AM »


LOL i did not even notice i missed those quote marks when i used it as the arguments, must have been fate ;)

shc

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: Sega Model 2 not load the games
« Reply #11 on: September 18, 2018, 12:57:44 PM »
With the trick of removing the quotes, it works for me. Now there's a little problem: How to get out of the Model 2 emulator? When push ESC the emulator remains minimized in window mode and you have to use the mouse to close it (which is a nuisance to play in a bartop)